TechBlogSD - Все для WordPress и WEB разработки
WEB и WordPress инструкции, новости, обзоры тем и плагинов

Фиаско с обновлением WordPress 5.5.2

327

Команда разработчиков WordPress в результате ряда ошибок выпустила некорректное обновление, которое сделало невозможным установку новых сайтов WordPress. Они приостановили выпуск обновления, пытаясь исправить это обновление, но это создало еще больше проблем, требующих экстренного обновления для устранения всех проблем.

Ошибочное обновление безопасности WordPress 5.5.2

Фиаско началось 29 октября 2020 года с планового обновления, предназначенного для устранения критических проблем безопасности. WordPress 5.5.2 был предназначен для предотвращения таких проблем, как подделка межсайтовых запросов, атаки XSS (межсайтовый скриптинг) и многое другое.

К сожалению, в обновлении также была обнаружена ошибка, которая приводила к сбою новых установок WordPress. Вот как WordPress объяснил ошибку:

«WordPress 5.5.2… делает невозможным установку WordPress на новый веб-сайт, для которого не настроено подключение к базе данных. Этот выпуск не влияет на сайты, на которых уже настроено соединение с базой данных, например, с помощью установщиков одним щелчком мыши или существующего файла wp-config.php ».

Чтобы решить эту проблему, WordPress остановил развертывание версии 5.5.2 на других сайтах. И тогда мошенническое обновление автоматически выполнилось.

Альфа-обновление WordPress случайно удалено

WordPress притормозил дальнейшие обновления. Но пока команда WordPress была занята подготовкой WordPress 5.5.3, чтобы исправить предыдущую ошибку, автоматические обновления WordPress начались снова.

Но поскольку версия 5.5.2 была недоступна, автоматизированная система WordPress выбрала альфа-версию WordPress для загрузки и установки 29 октября. Эта альфа-версия не предназначалась для установки и содержала проблемы.

Ошибки WordPress 5.5.3 Alpha

Проблема с установкой WordPress Alpha заключалась в том, что она вводила дополнительные темы WordPress и устанавливала Akismet.

Якобы в этих темах нет ничего плохого. Но издатели, которые решат не удалять их, будут вынуждены постоянно обновлять их. Отсутствие обновления этих тем может в будущем создать угрозу безопасности.

Согласно объявлению WordPress :

«Сегодня система автообновлений WordPress обновила некоторые сайты с версии 5.5.2 до версии 5.5.3-alpha. Это произошло из-за ошибки, вызванной подготовкой к выпуску 5.5.3.

Альфа-версия 5.5.3 на тот момент была функционально идентична 5.5.2, поскольку разработка 5.5.3 не велась, однако могли быть внесены следующие изменения:

Темы по умолчанию «Двадцать» устанавливаются как часть предрелизного пакета. Плагин «Akismet» устанавливается как часть пакета предварительной версии ».

Веб – страницы, по- видимому, для выпуска альфа, был опубликован 29 октября 2020 года, по- видимому, ошибочно помечены как версии 5.4.3. Я говорю ошибочно, потому что WordPress 5.4 был выпущен в марте 2020 года, и нет смысла возвращаться с WordPress 5.5 на версию 5.4.

На кажущейся ошибочной странице обновления 5.4.3 содержится документация, идентичная информации, опубликованной для версии 5.5.2.

WordPress 5.5.3

Последнее обновление, версия 5.5.3, – это все, чем должна была быть версия 5.5.2, только без связанных с этим проблем. WordPress 5.5.3 исправляет все проблемы, появившиеся в версии 5.5.2.

WordPress объяснил:

«Этот сервисный выпуск исправляет проблему, появившуюся в WordPress 5.5.2, из-за которой невозможно установить WordPress на новый веб-сайт, для которого не настроено подключение к базе данных. Этот выпуск не влияет на сайты, на которых уже настроено подключение к базе данных, например, с помощью установщиков одним щелчком мыши или существующего файла wp-config.php.

Если вы не используете 5.5.2 или у вас отключены автоматические обновления для второстепенных выпусков, пожалуйста, обновите вручную до версии 5.5.3, загрузив WordPress 5.5.3 или открыв Панель инструментов → Обновления и нажмите «Обновить сейчас».

Автоматизируйте свою рекламу в Google, Facebook и Microsoft.
Автоматизируйте успешные рекламные стратегии Google, Facebook и Microsoft. 100% БЕСПЛАТНО. Делайте больше за меньшее время с нашей БЕСПЛАТНОЙ, отмеченной многими наградами, платформой контекстной рекламы.

Что пошло не так

Проблемы были введены командой разработчиков, потому что не было официальной документации о том, как остановить обновление WordPress. Из-за этого команда WordPress остановила обновление, открыв дверь для альфа-версии, чтобы начать развертывание.

Эта проблема решена, поэтому такой сценарий больше не повторится.

Согласно официальным техническим деталям :

«… Этого больше не будет. Кажется, сейчас самое время задокументировать правильный и надлежащий способ «остановки» незавершенного выпуска, чего, честно говоря, раньше не предпринималось. Остановить выпуск на самом деле довольно просто, если они внесли правильные изменения, поэтому, хотя их попытка была разумным предположением, она оказалась ошибочной.

Система выпуска сложна, и попытки сделать с ней то, что не ожидалось и не задокументировали, приводили к неожиданным результатам. Это будет улучшено за счет документации, лучшего кода и управления самой системой выпуска ».

Проверьте свою установку WordPress

Издателям рекомендуется убедиться, что они обновлены до версии 5.5.3. Версии до 5.5.2 содержат проблемы безопасности, поэтому очень важно обновиться до последней версии.

Техническая версия WordPress 5.5.3 не содержит извинений за проблемы, только «благодарность и поддержку» команде разработчиков за исправление возникших проблем.

Источник записи: https://www.searchenginejournal.com

Leave A Reply

Этот веб-сайт использует файлы cookie для улучшения вашего опыта. Мы предполагаем, что вы согласны с этим, но вы можете отказаться, если хотите. ПринимаюПодробнее